Issue Details
We have identified an issue where an authentication window may be displayed more than once when a user logs in with a Device Certificate via Microsoft Authenticator with the following steps.
1. Launch Microsoft Authenticator on a Microsoft application including Outlook.
2. Tap "Log in with Device Certificate" after the HENNGE Access Control authentication window is displayed.
3. After loading, the HENNGE Access Control authentication window will be displayed once again.
4. When tapping "Log in with Device Certificate" again, the login will be successfully completed based on the kind of your Device Certificate, such as personal, shared, or passwordless.
Root Cause
The root cause of this issue, such as whether it is an issue on the iOS side or Microsoft side, is uncertain at this point.
Therefore we have not found any technical solutions to this issue yet though we are fully aware of it.
Temporary Solution
By tapping "Log in with Device Certificate" for the second time, the user can successfully login.
Please tap the button twice as a temporary solution. We apologize for the inconvenience.