This article is based on the product specifications as of July 2026.
Depending on the Tadrill Training Emails delivery method, click the item for the displayed Error message to view the resolution.
Note: For the DMI delivery configuration status, please refer to the following help center articles.
[Tadrill] DMI (Direct Message Injection) Settings (Microsoft 365)
[Tadrill] DMI (Direct Message Injection) Settings (Google Workspace)
Note: If an Error not listed below is displayed, or if the issue persists after performing the resolution steps, please contact HENNGE One Technical Support with the following Info.
- Target Training name and Training Start date and time
- Target users
- Error message
Table of Contents
- Training Emails delivery method: SMTP delivery
- Training Emails delivery method: DMI delivery (Microsoft365)
- Training Emails delivery method: DMI delivery (Google Workspace)
Training Emails delivery method: SMTP delivery
550 5.1.1/NoSuchUser/The email account that you tried to reach does not exist.
The recipient's mailbox does not exist, or the Training Email address is incorrect.
Please check the recipient's Settings.
550 5.2.1
The mailbox exists, but it is Disabled or is unable to receive messages.
Please check the recipient's Settings.
550 5.2.2
The mailbox capacity limit has been exceeded.
Please check the recipient's Settings.
550 5.4.1 Recipient address rejected: Access denied
The receiving Training Emails System rejected the message before delivery.
This may occur if the recipient account has not been Enabled or assigned a license, the Domain has not been authorized, or delivery has been blocked by a Training Emails flow rule.
Please check the recipient's Settings.
550 5.7.1
Delivery was rejected by the security or authorization policy of the receiving Training Emails System.
This may occur due to restrictions on the sender or recipient Domain, blocking by Training Emails flow rules, detection by security Filters, or if the sender is not registered in the allowlist(whitelist).
Please check the recipient's Settings.
Training Emails delivery method: DMI delivery(Microsoft 365)
MailboxNotEnabledForRESTAPI
Microsoft Graph cannot access the mailbox.
The mailbox may be inactive, soft-deleted, hosted in an on-premises environment, or may not be a valid Exchange Online mailbox.
Please check the recipient's Settings.
Authorization_RequestDenied/Forbidden/403
Access to Microsoft Graph was denied.
The required permissions may be missing in the DMI Integrations Settings, or admin consent may not have been granted.
Tadrill DMI must be reconfigured. Please Contact Us at HENNGE One Technical Support.
ResourceNotFound/Request_ResourceNotFound/404
The Target users or mailbox could not be found.
Please check the recipient's Settings.
ErrorQuotaExceeded/Insufficient Storage/507
The destination mailbox capacity has exceeded its limit, so the Training Email cannot be saved(received).
Please check the recipient's Settings.
Training Emails delivery method: DMI delivery(Google Workspace)
invalid_grant: user likely does not exist or is suspended
The user may not exist, or the account may be suspended.
Please check the recipient's Settings.
access_denied: client authorization has been revoked
The client's authorization has been revoked.
Tadrill DMI must be reconfigured. Please Contact Us at HENNGE One Technical Support.
mail service not enabled
Gmail is not Enabled for the Target users.
Please check the recipient's Settings.
Translation Disclaimer
This article has been automatically translated from the original Japanese version for your convenience.
While we strive to ensure accuracy, we cannot guarantee its reliability or completeness.
In the event of any discrepancies or questions regarding the content, the official Japanese version shall prevail.